mirror of
https://git.dev.opencascade.org/repos/occt.git
synced 2025-04-02 17:46:22 +03:00
The basic implementation of VCPKG as a beta version. By default will be disabled. To enable needs to remove CMake cache and reconfigure with BUILD_USE_VCPKG flag to ON. The current version do not support whole list of 3rd-party, only limited. and VCPKG_ROOT reachable as a CMake or env variable Add vcpkg support for FFmpeg and Jemalloc, including configuration files and patches.
13 lines
358 B
Diff
13 lines
358 B
Diff
diff --git a/configure.ac b/configure.ac
|
|
index 3115504e2..ffb504b08 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -749,6 +749,7 @@ case "${host}" in
|
|
so="dll"
|
|
if test "x$je_cv_msvc" = "xyes" ; then
|
|
importlib="lib"
|
|
+ JE_APPEND_VS(CPPFLAGS, -DJEMALLOC_NO_PRIVATE_NAMESPACE)
|
|
DSO_LDFLAGS="-LD"
|
|
EXTRA_LDFLAGS="-link -DEBUG"
|
|
CTARGET='-Fo$@'
|